Issues signing in to Harvest via Google
Incident Report for Harvest
Resolved
Good news—The issue signing in to Harvest via Google has been resolved! Sorry for any trouble this caused.
Posted over 1 year ago. Apr 05, 2016 - 20:04 UTC
Investigating
The team is currently investigating some issues signing in to Harvest via Google, and will post a more detailed status update here as soon as possible.
Posted over 1 year ago. Apr 05, 2016 - 19:06 UTC