Issue with Harvest Timesheets
Incident Report for Harvest
Resolved
We found the source of the issue and have a fix in place. You may need to refresh your browser.
Posted over 1 year ago. Aug 21, 2015 - 10:20 EDT
Investigating
The team is currently investigating issues with Harvest timesheets, and will post a more detailed status update here as soon as possible.
Posted over 1 year ago. Aug 21, 2015 - 10:15 EDT