Harvest Performance Issues
Incident Report for Harvest
Resolved
The availability issue is now resolved, and all users should now have access to their Harvest accounts. We apologize for the disruption, and thank you for your patience!
Posted about 2 months ago. Mar 09, 2017 - 13:17 EST
Investigating
The team is currently investigating an issue causing intermittent availability of Harvest, and will post a more detailed status update here as soon as possible.
Posted about 2 months ago. Mar 09, 2017 - 12:44 EST