Problems Adding New People to Harvest Accounts
Incident Report for Harvest
Resolved
The issue has been resolved, and customers experiencing the problem should now be able to log in to the Harvest accounts they have been added to. Sorry again for the inconvenience.
Posted over 1 year ago. Oct 07, 2015 - 16:55 EDT
Identified
We have deployed a fix for this problem, and are working to resolve any issues for previously affected accounts.
Posted over 1 year ago. Oct 07, 2015 - 16:46 EDT
Investigating
We have received multiple reports of customers seeing errors when adding new People to their Harvest accounts, or when newly added People attempt to join Harvest accounts. We are working to identify and resolve the problem and will keep you updated with the progress. Really sorry for the inconvenience here.
Posted over 1 year ago. Oct 07, 2015 - 16:27 EDT