Problem Accessing Harvest
Incident Report for Harvest
Resolved
We've identified and remedied the issue preventing some users from accessing Harvest. Everything is back to normal!
Posted almost 2 years ago. Dec 15, 2015 - 16:30 UTC
Investigating
The team is currently investigating users having trouble accessing Harvest, and will post a more detailed status update here as soon as possible.
Posted almost 2 years ago. Dec 15, 2015 - 16:25 UTC