Outgoing Email service outage
Incident Report for Harvest
Resolved
The email service is fully operational again. All queued emails have been sent. Sorry for the interruption!
Posted May 31, 2024 - 08:54 UTC
Identified
Harvest currently can't send emails due to a vendor's outage. All pending emails will be delivered once the service resumes.
Posted May 31, 2024 - 08:15 UTC
This incident affected: Harvest Email Service.