Harvest Disruption: Investigating Ongoing Issue

Incident Report for Harvest

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:04 UTC

Investigating

We’re aware of an issue affecting Harvest and are actively looking into it. Our team is working to resolve this as quickly as possible. We will provide an update within the next 30 minutes.
Posted Mar 23, 2026 - 15:53 UTC
This incident affected: Harvest Application and API.