GetHarvest.com Performance Issues
Incident Report for Harvest
Resolved
The third-party issues have been resolved. Access to getharvest.com is restored. Thank you for your patience!
Posted Mar 02, 2022 - 18:22 UTC
Update
GetHarvest.com is still experiencing issues. If you have questions regarding your Harvest account, you can email support@harvestapp.com for our support team. You can also sign in to your account by visiting https://id.getharvest.com/accounts.
Posted Mar 02, 2022 - 16:15 UTC
Monitoring
GetHarvest.com is currently experiencing issues due to a third-party provider outage. We are monitoring the situation and will post an update here as soon as possible.
Posted Mar 02, 2022 - 14:59 UTC