Forecast Service Degradation: Investigating Performance Issue
Incident Report for Harvest
Resolved
The issue has been resolved. However, if you are still experiencing issues loading Forecast, please try clearing your browser's cache/cookies as shown in this guide: https://bit.ly/3BXyNJY. If you then continue to have any problem, reach out to our team at http://www.getharvest.com/contact.
Posted Oct 23, 2024 - 18:26 UTC
Update
The issue is intermittent for some customers, and we are continuing to investigate the problem. We will provide an update within the next 60 minutes.
Posted Oct 23, 2024 - 17:56 UTC
Investigating
We’re aware of a performance issue affecting Forecast. Our team is actively looking into it and working to resolve the issue as quickly as possible. We will provide an update within the next 30 minutes.
Posted Oct 23, 2024 - 17:24 UTC
This incident affected: Forecast Application.