Forecast outage

Incident Report for Harvest

Resolved

Issue has been resolved.
Posted Nov 25, 2025 - 16:32 UTC

Investigating

We're seeing a full outage on Forecast. Team is on it.
Posted Nov 25, 2025 - 15:52 UTC
This incident affected: Forecast Application.