Login issues with Harvest Apps
Incident Report for Harvest
Resolved
All of our apps are functioning normally again.
Posted Sep 16, 2014 - 08:26 UTC
Investigating
We're working on an issue with the login, and sync capabilities of our iOS, Mac, and Android Apps.
Posted Sep 16, 2014 - 07:54 UTC