Harvest Performance Issues
Incident Report for Harvest
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 17:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2020 - 17:04 UTC
Investigating
The team is currently investigating performance issues with Harvest and external service connections (Forecast, calendars, etc.). We will post a more detailed status update here as soon as possible.
Posted Mar 25, 2020 - 16:44 UTC
This incident affected: Harvest Application and API.