Email Delays for Harvest and Forecast
Incident Report for Harvest
Resolved
The deferred queues for our email provider went back down to zero. Issue resolved.
Posted Jun 07, 2022 - 15:40 UTC
Investigating
We are investigating delays with email delivery from Harvest and Forecast with our email provider.
Posted Jun 07, 2022 - 15:00 UTC
This incident affected: Harvest Email Service.