Forecast SSL incident

Incident Report for Harvest

Resolved

Forecast is back up and serving the correct certificate. This incident has been resolved. We're sorry for the inconvenience.
Posted Aug 25, 2021 - 11:18 UTC

Identified

Forecast is displaying an error page due to a problem with its SSL certificate. We are actively fixing the issue.
Posted Aug 25, 2021 - 11:08 UTC
This incident affected: Forecast Application.