Harvest Service Degradation: Error rate and email delivery delays

Incident Report for Harvest

Resolved

We have verified that the applied changes have fixed the investigated issues.
We're sorry for the inconvenience and appreciate your understanding while we restored full service.
Posted Jul 21, 2025 - 08:22 UTC

Identified

We've identified the root causes and are applying fixes to the database as well as taking measures to improve the email delivery rate.
Posted Jul 21, 2025 - 07:52 UTC

Investigating

We’re aware of an elevated error rate affecting Harvest, Harvest ID and Forecast. Some emails sent by Harvest are currently delayed.
Our team is actively looking into it and working to resolve the issue as quickly as possible. We will provide an update within the next 30 minutes.
Posted Jul 21, 2025 - 07:13 UTC
This incident affected: Forecast Application, Harvest Application and API, and Harvest Email Service.