Harvest performance issues

Incident Report for Harvest

Resolved

Apologies to customers who saw errors on Harvest earlier today. Thanks for your patience while we resolved the performance issues.
Posted Jul 26, 2021 - 14:29 UTC

Monitoring

At this time we believe the performance issue from earlier in the day has been mitigated. The team continues to monitor Harvest performance for all customers.
Posted Jul 26, 2021 - 14:16 UTC

Update

Thanks for your patience while we continue to investigate the cause of the earlier issue, and carefully monitor Harvest performance for all customers.
Posted Jul 26, 2021 - 14:01 UTC

Investigating

We are investigating a performance issue which might have resulted in some customers seeing errors on Harvest. Thank you for your patience while we investigate the issue.
Posted Jul 26, 2021 - 13:36 UTC
This incident affected: Harvest Application and API, Harvest Background Jobs, Harvest Email Service, and Harvest Third Party Integrations.