GetHarvest.com Performance Issues
Incident Report for Harvest
Resolved
Access to GetHarvest.com is now fully restored. Thank you for your patience!
Posted Mar 02, 2022 - 20:10 UTC
Update
GetHarvest.com is now operating without issue, and we are continuing to monitor the performance. Thank you for your patience during the outage today.
Posted Mar 02, 2022 - 19:33 UTC
Monitoring
GetHarvest.com is still experiencing issues due to a third-party outage. You can sign in to your account by visiting https://id.getharvest.com/accounts. If you have questions regarding your Harvest account, email support@harvestapp.com.
Posted Mar 02, 2022 - 18:42 UTC