Harvest Degraded Performance

Incident Report for Harvest

Resolved

The incident has been resolved.
Posted Nov 21, 2025 - 15:33 UTC

Investigating

We're seeing elevated error rates across Harvest. Investigation is in progress.
Posted Nov 21, 2025 - 13:50 UTC
This incident affected: Harvest Activity Log, Harvest Application and API, Harvest Background Jobs, Harvest Email Service, Harvest Homepage, Harvest Mobile, and Harvest Third Party Integrations.