Email Delays for Harvest and Forecast

Incident Report for Harvest

Resolved

This incident has been resolved.
Posted Dec 15, 2021 - 17:03 UTC

Monitoring

Email delivery times have returned to normal for Harvest and Forecast. We are monitoring email delivery for any further issues.
Posted Dec 15, 2021 - 16:32 UTC

Identified

Email delivery times are improving for Harvest and Forecast. Our email provider has identified an issue that's causing the delays and working to resolve it.
Posted Dec 15, 2021 - 16:08 UTC

Investigating

We are investigating delays with email delivery from Harvest and Forecast.
Posted Dec 15, 2021 - 15:54 UTC
This incident affected: Harvest Email Service.