Email Delays for Harvest and Forecast
Incident Report for Harvest
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 10:01 UTC
Monitoring
Our email provider has implemented a fix and we're seeing our email queues reducing.
Posted Sep 16, 2022 - 09:23 UTC
Identified
Our email provider is having issues, so our emails are going to be delivered with some delay. We appreciate your patience as they work through this, and will update you as soon as we have news.
Posted Sep 16, 2022 - 08:15 UTC
This incident affected: Harvest Report Exports by Email and Harvest Email Service.