Forecast Service Degradation: Investigating Performance Issue

Incident Report for Harvest

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 14:44 UTC

Investigating

We’re aware of a performance issue affecting Forecast. Our team is actively looking into it and working to resolve the issue as quickly as possible. We will provide an update within the next 30 minutes.
Posted Jul 28, 2025 - 14:09 UTC
This incident affected: Forecast Application.