Email Delays for Harvest and Forecast
Incident Report for Harvest
Resolved
Our queues have been cleared.
Posted Jun 09, 2022 - 14:27 UTC
Monitoring
A fix has been implemented by our email provider and the email queues are going down. We'll update you once they are all cleared.
Posted Jun 09, 2022 - 13:44 UTC
Identified
Our email provider is having issues, so our emails are going to be delivered with some delay. We appreciate your patience as they work through this, and will update you as soon as we have news.
Posted Jun 09, 2022 - 12:38 UTC
This incident affected: Harvest Email Service.