Billing and Harvest Setting Unavailable for Some Customers
Incident Report for Harvest
Resolved
The issue has been resolved and things should be working as normal. If you experience any issues, please let us know!
Posted Sep 16, 2020 - 17:30 UTC
Monitoring
The payment processor has implemented a fix and we're monitoring the results.
Posted Sep 16, 2020 - 16:47 UTC
Update
The issue has been identified by the payment processor, and they're working on a fix. We'll continue to update till the issue is resolved.
Posted Sep 16, 2020 - 16:37 UTC
Identified
The payment processor Harvest uses to process your credit card payments to us is experiencing issues. This is temporarily causing issues for some Harvest customers who are trying to reach the Settings section of Harvest, or do activities related to their Harvest billing. This will NOT cause issues for Harvest customers using a payment gateway for invoices they send their clients.
Posted Sep 16, 2020 - 16:22 UTC
This incident affected: Harvest Application and API.