Outgoing Email service outage
Incident Report for Harvest
Resolved
All queued email has been sent and the email service is fully operational again. Sorry for the inconvenience this has caused.
Posted May 27, 2024 - 14:12 UTC
Monitoring
Our vendor is accepting email again and our systems are working through the backlog of queued outbound email.
Posted May 27, 2024 - 13:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2024 - 13:36 UTC
Identified
Harvest currently can't send emails due to a vendor's outage.
Posted May 27, 2024 - 13:36 UTC
This incident affected: Harvest Email Service.