Outgoing Email service outage
Incident Report for Harvest
Resolved
Email service is now operating correctly.
Posted Dec 30, 2023 - 02:44 UTC
Monitoring
A fix has been implemented, and we are monitoring to ensure that emails are being sent correctly.
Posted Dec 30, 2023 - 01:32 UTC
Investigating
We are currently investigating an issue with our outgoing email service.
Posted Dec 29, 2023 - 23:59 UTC
This incident affected: Harvest Email Service.