Chrome extension broken for some users
Incident Report for Harvest
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 11:27 UTC
Identified
The Chrome extension is not working for some users. Our team has submitted an update to Google and is awaiting approval. During this time, the extension page on the Chrome Web Store is unavailable. We will update this status once the new version is available through Chrome.
Posted Jan 29, 2024 - 21:58 UTC
This incident affected: Harvest Third Party Integrations.