Outgoing Email service outage
Incident Report for Harvest
Resolved
Email service is now operating correctly.
Posted Jan 08, 2024 - 18:08 UTC
Update
We are still working through the remaining backlog of delayed emails but expect full resolution shortly.
Posted Jan 08, 2024 - 18:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 08, 2024 - 17:03 UTC
Monitoring
We have resolved the issue with our email vendor and our systems are now going through the backlog of email that has queued up.
Posted Jan 08, 2024 - 17:03 UTC
Update
Fixes have been implemented and we are currently working with our email vendor to restore the email service as quickly as possible.
Posted Jan 08, 2024 - 16:31 UTC
Identified
We have identified the issue and are currently working with our email vendor to restore the email service as quickly as possible.
Posted Jan 08, 2024 - 15:28 UTC
Investigating
We are currently investigating an issue with our outgoing email service.
Posted Jan 08, 2024 - 14:31 UTC
This incident affected: Harvest Email Service.